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1 QUICK GUIDE: XRS-FP SETUP & ANALYSIS FLOWCHART 

A flowchart illustrating the steps involved in the basic setup and configuration of XRS-FP for standardless 

analysis is shown below in Figure 1: 

 

Figure 1. XRS-FP Flowchart. This flowchart describes the steps needed for basic setup and configuration of XRS-FP. 
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2 XRS-FP SETUP & STANDARDLESS ANALYSIS TUTORIAL 

The following tutorial describes the basic setup of a general XRF system for analysis, the configuration of 

XRS-FP, energy calibration using Amptek hardware (although briefly, as this is discussed in detail in the 

“XRS-FP How to Calibrate with Amptek HW” document) and standardless analysis of stainless steel 316 

(SS 316). This tutorial along with associated spectra (*.mca) and application (*.tfr) files guides an XRS-FP 

software user through the basic setup of their XRF system and subsequent standardless analysis of SS 

316. This may be achieved in one of two ways: 

 

a) Using a live XRF setup for hardware (HW) control and data acquisition (note: that this is a generic 

guide and the particulars of a given XRF system will vary from instrument to instrument). 

b) Using the provided spectra (*.mca) and application (*.tfr) files without HW to emulate the setup 

and analysis. 

Note: It is not necessary to connect the XRS-FP program to any hardware unless you wish to acquire 

spectra directly with XRS-FP. For BOTH methods listed above, the provided spectra (*.mca) and application 

(*.tfr) files will be used. If using method (a) various input parameters may need to be changed depending 

on the type of HW, geometry, etc., used for a specific XRF system. 

 

 
1. If using a live XRF system ensure that the hardware (HW) components are setup in the desired 

geometry and connected appropriately (power cables, signal cables, etc.). Please see appropriate 

guides proved by the HW manufacturer(s) for correct setup and safety measures.  

 

 
Figure 2. XRF Generic Setup. Above is a simple schematic of an XRF setup, including the source, detector and DPP. Note 
that for live acquisition both the source (x-ray tube) and DPP need to be connected to a computer for data acquisition 
and hardware (HW) control, and for running the XRS-FP analysis software; however, if working offline on previously 
acquired data or if using the files provided with this tutorial without HW there is obviously no need for the HW to be 
connected. 
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2. Launch XRS-FP – either run the software from the Windows Start-Programs menu, or double-click 

on a shortcut (if one has been created on the desktop).  First, the splash screen will load and then 

the Auto-Mode FP Analysis window and a separate Spectra-X window will be displayed.  The 

splash screen will briefly show the values and options for the HASP security plug, and the software 

libraries that have been loaded. This can also be displayed by selecting the Help -> About menu 

option. 

 

3. From the Auto-Mode FP Analysis window, click Expert Mode (Fig. 3 below).  This will show the 

contents of the “Master.tfr” file (see section 4.1 of the “XRS-FP Software Guide” for additional 

information on loading the software). Ensure the “Update Spectra” option is checked (on) (Fig. 3). 

 

 
Figure 3. Auto-Mode FP Analysis Panel. Select  the “Expert Mode” button. Ensure the “Update Spectra” option is 

checked (on). 
 

 
4. From the XRS-FP Expert Panel:  Select File -> Open -> “C:\CrossRoads Scientific\XRS-FP 

Basic Setup SS316 Tutorial Files\SS316 - Initial.tfr” (or equivalent location). See Fig. 4 below. 

 
Figure 4. File Open Menu. Open the stainless steel SS316 TFR file, e.g. “SS316.tfr”. 
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This TFR (“Thin Film Report”) file, or configuration file, acts as a template for this tutorial. A TFR 

file contains the elements and calibration coefficients (if employed) that are required for routine 

XRF analysis, along with a description of the various analysis and system setup. Although the 

Component Table, Elements Table and Thickness information have no results at this point, the 

Measurement & Processing information (spectrometer configuration) is already pre-defined and 

loaded for this application. See Figure 5 below. 

 

 
Figure 5. XRS- FP Expert Panel. The “SS316 - Initial.tfr” file acts as a template for this application. Note that this file 
contains the proper Measurement & Processing information for this application (i.e. spectrometer configuration 
information). Also note that in the “Thickness Information” table the “Type” is set to “Bulk” and it is “Normalized” to 
100%. 

 

Note: If you are connected to HW, various input parameters may need to be changed in the TFR 

file depending on the type of HW, geometry, etc. used for a specific XRF system. The following 

steps will outline which parameters may need to be changed. Regardless of the method used for 

this tutorial (i.e. with or without HW), the steps outlined below will guide you through the process 

of setting up and configuring XRS-FP for use with an XRF system. 

 

 

a. Specimen Component Table: This is where the sample components are added to the 

TFR (also see section 5.2, “XRF Elemental FP Calibration or Standardization,” of the XRS-

FP Software Guide).  Components can be elements or compounds. For this tutorial, enter 

Cr as the first component. Having entered a component in the table, use the down arrow 
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key of your computer keyboard to enter additional components. Now enter Mn as the 

second component, Fe as the third component, Ni as the fourth component, Mo as the fifth 

component and Si as the sixth component. Notice that the “Type” is automatically set to 

“Calc” so the SW will calculate the concentration of each component; however, notice that 

the “Type” for Si is set to “Fixed” and the Concentration is set to 1.0000. The reason for 

this is there are several minor elements such as Si, S, P and C which cannot be analyzed. 

To account for this, we use 1% Si as a rough estimate. In the Specimen Component Table 

enter “Fixed” as the component “Type” for Si and set the “Conc” to 1.000. See entered 

components below in Figure 6. 

 

 
Figure 6. XRS- FP Expert Panel. The components, Cr, Mn, Fe, Ni, Mo and Si, are now filled in for this application. Notice 
that the elements are automatically entered as the components are entered and that the highest energy analyte line is 
also automatically selected as the components are entered (e.g. the Cr Kα line was selected when Cr was entered). 

 

Note: to create a “clean sheet” for future analysis (select File -> New from the XRS-FP 

Expert Panel. This will clear all of the application information, i.e., Component Table, 

Elements Table and Thickness information; however, the Measurement information 

(spectrometer configuration) will be retained.   

 

b. Element Table: As components are defined (see above), the “Element Table” is filled in 

and the line is set to the highest energy line that gets excited by the source kV. Note that 

the line must have an associated edge energy that is below the specified kV in the 

Condition Table, otherwise the intensity will be reported as zero. For example, the Cr Kα 

line is selected when Cr was entered for this application (see Fig. 6 above). 
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Note: In general, the appropriate line for analysis (Ka, Kb, La, Lb, Lg or Ma), MUST be 

selected. Although this line is filled in by the software, it is important to check that it is the 

best one for the application at hand. 

 

c. Thickness Table: Accurate XRF analysis requires definition of the thickness of the sample 

material. In the case of this tutorial, the stainless steel is infinitely thick, which means that 

it has greater thickness than the escape depth of the highest energy line. This is defined 

as “Type” “Bulk” in the “Thickness Table” and is the default type setting. The default 

thickness for bulk analysis is zero (0). The “Normalize” field of the thickness table refers to 

component concentrations. For standardless analysis the results MUST be normalized 

(see Fig. 6 above). Normalizing to 100% is not required for all bulk analyses, but is often 

employed. 

 
5. From the XRS-FP Expert Panel:  Select Setup -> Detector. This is where all the detector properties 

are set. If using HW with this tutorial, change the parameters so that they correspond to the XRF 

system in use. Otherwise, make sure all parameters are identical to those shown below in Figure 

7. Select “OK” to exit the dialog and save the parameters. Note that the most important parameters 

involved in the detector setup are the detector material, thickness, resolution and window type.  

 

 
Figure 7. Setup Detector & Window Parameters Dialog. Check that the “Detector Type,” “Window Type,” and all 
corresponding parameters are as shown here, unless HW is being used with this tutorial. 

6. Now, from the XRS-FP Expert Panel: Select Setup -> Tube/Source. This is where all the source 

properties are set. If using HW with this tutorial, change the parameters so that they correspond to 
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the particular source of the XRF system in use. Otherwise, make sure all parameters are identical 

to those shown below in Figure 8. Note that the most important parameters involved in the source 

setup are the tube type, model, tube anode material (element) and the window type. Select “OK” 

to exit the dialog and save the parameters. 

 

 
Figure 8. Setup Tube Parameters Dialog. Check that the “Source Type,” “Target Element,” “Window Type” and all 
corresponding parameters are as shown above, unless HW is being used with this tutorial. The four different  source types are 
illustrated here, a) side window tube, b) end window tube, c) transmission target tube and d) radioisotope.  

 
 

Figure 8 displays schematic diagrams of the four source types - side window tube, end window 

tube, transmission target tube and radioisotope source - that can be selected from the XRS-FP 

Setup -> Tube/Source dialog. The data acquired for this tutorial used a transmission target tube. 

The source angle parameters and all other associated geometry of the XRF system are very 

important and will be discussed further in step 7 in more detail. 

 

7. Again from the XRS-FP Expert Panel: Select Setup -> Geometry. This is where all the angle and 

distance parameters are set. If using HW with this tutorial, change the parameters so that they 

correspond to the particular geometry of the XRF system in use. Otherwise, make sure all 

parameters are identical to those shown below in Figure 9. Note that the most important parameters 

involved in the geometry setup are the incidence angle, take-off angle, the tube-to-sample distance 

and the sample-to-detector distance. Select “OK” to exit the dialog and save the parameters.  
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Figure 9. Setup Geometry Dialog. Check that the angle and distance parameters are as shown here, unless HW is being 
used with this tutorial. See Figures 10 and 11 below for explanation of the various angle and distance parameters. 
 

 

Figures 10 and 11 below show schematic diagrams of the various angle and distance parameters 

involved in the geometry setup of an XRF system.  

 

Figure 10. Geometry - Angles Schematic. All angle parameters listed for the geometry setup are described here. 
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Figure 11. Geometry - Distances Schematic. All distance parameters listed for the geometry setup are described here. 

 

 

 

8. From the XRS-FP Expert Panel: Select Setup -> MCA/DPP. If working offline (without HW) just 

enter the number of channels, with the eV per channel or range (keV). If working with HW please 

see the following document for stepwise details on performing an energy calibration in XRS-

FP (with Amptek HW):  “XRS-FP How to Calibrate with Amptek HW.doc”. Note that the two 

most important parameters involved in the DPP/MCA setup are the number of channels and range. 

Figure 12 shows the Amptek DPP/MCA Acquisition Setup parameters. 
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Figure 12. Setup MCA/DPP Dialog.  Amptek DPP/MCA Acquisition Setup showing the No. Channels, eV/Ch 
and Range. 

 
 
 

9. Now select: Setup -> Processing from the XRS-FP Expert Panel. This will display the “Setup 

Processing Parameters” Dialog shown below in Figure 13 (see section 14.3, “Process Spectrum,” 

of the XRS-FP Software Guide for more detail). Note that spectra supplied for this tutorial have 

been energy adjusted (see section 12.11, “Setup Spectrum Adjust” of the XRS-FP Software Guide). 

To avoid doing a double adjust in this case, verify that the “Auto Adjust Spectrum Gain & Offset on 

Load” is unchecked in the “Setup Processing Parameters” dialog. See Figure 13 below. Note: if 

you are using your own spectra, you may need to change the Mn-Ka FWHM to a higher value. 
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Figure 13. Setup Processing Parameters Dialog. Observe that the “Auto Adjust Spectrum Gain & Offset on Load” button 
is unchecked if using the files supplied with the SS316 tutorial, as the spectra have already been energy adjusted. 

 

 

10. Then select:  Setup -> Quant from the XRS-FP Expert Panel. Check that the radio button for the 

“Quant Analysis Method” is set to “Fundamental Parameters” (FP) and the “FP Calibration Mode” 

is set to “Standardless” (see Fig. 14 below). 
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Figure 14. Setup Quant Dialog.  Select the “Fundamental Parameters” method and the “Standardless” mode. 

 
 

11. At this point our application, stainless steel 316, has been defined, XRS-FP has been configured 

for the setup of the XRF system used for acquisition (either the live XRF system in use or for the 

system previously used to collect the tutorial files) and it is calibrated (energy calibration). If using 

the supplied tutorial files without hardware proceed to step 12 below. If using hardware to do a 

live acquisition, ensure that the DPP is connected and now turn the source x-rays on (HV ON). 

Details for a specific hardware setup are beyond the scope of this tutorial; however, please ensure 

that all safety measures are followed according to the hardware manufacturer guidelines! Once the 

system is running and stable, acquire a spectrum of the stainless steel 316 standard. Select File -

> Save As from the XRS-FP Expert Panel and save the spectrum as, for example, “SS316.mca” 

(or equivalent). 

 

12. The next step is to extract intensities from the stainless steel 316 spectrum (*mca file). Select  

File -> Open ->“C:\CrossRoads Scientific\XRS-FP\Basic Setup Tutorial\SS316.mca”  

(or equivalent location). See Figures 15 and 16 below. Note that the spectra provided for this tutorial 

are already adjusted and in calibration. 
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Figure15. File Open Menu. Open the stainless steel spectrum, *.mca file (e.g. SS316.mca). 
 

 

 
Figure16. Spectra-X Window. Loaded stainless steel mca file (SS316.mca). 

 

 

13. To extract intensities from the stainless steel 316 spectrum, select Process -> Spectrum -> All, 

from the XRS-FP Expert Panel. Notice that there are now intensities displayed for each element in 

the “Element Table” (see Fig. 17 below). 
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Figure 17. XRS- FP Expert Panel. Note that intensities are now displayed for each element in the “Element Table.” 

 

 

14. Then select:  Process -> Analyze from the XRS-FP Expert Panel. Notice that there are now 

concentrations displayed for each component in the “Component Table” (see Fig. 18 below). 

 

 
Figure 18. XRS- FP Expert Panel. Observe that the concentration for each component is now displayed in the “Specimen 
Component Table.” 

 



XRS-FP Setup Tutorial  Page 18 of 22 

CrossRoads Scientific   21-May-14 

 
15. Now save the TFR file by selecting File -> Save As from the XRS-FP Expert Panel. This can be 

saved as “C:\CrossRoads Scientific\XRS-FP Basic Setup SS316 Tutorial Files\SS316-

StandardlessAnalysis.mca” or as an alternate filename of choice. The analysis results should be 

similar to those shown below in Figure 19. 

 

 
Figure 19. SS316 Analysis Results. Concentrations for the five calculated components are shown here. 

 

 

16. For comparison, Figure 20 below shows average compositions for SS316.  
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Figure 20. SS316 Average Composition. Average composition for SS316 is shown here. 
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3 APPENDIX 

XRS-FP is analysis software for use with X-Ray Fluorescence (XRF) Spectrometry, a widely used 

analytical technique. XRF analysis is based on the fact that incident x-rays excite atoms in a sample 

through ionization (the loss of an electron), which then emit characteristic radiation (x-rays of a 

particular energy) when they relax (an inner shell is filled by an electron from an outer-level shell), see 

Figure 21 below (for more detail see the XRS-FP Software Guide v51X, section 2 “About X-ray  

 

Figure 21. XRF Basics. a) Interaction of an x-ray photon with an atom (of sufficient energy), b) ionization of the atom by 
ejection of a core shell electron, c) vacancy filled by higher shell electron resulting in emission of an x-ray (photon). d) 
Schematic illustrating steps (a) through (c) including the emission of a characteristic Kα x-ray. d) Chemical elements emit 
characteristic radiations unique to each element when subjected to appropriate excitation. 
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Fluorescence”). A detector and signal processing electronics measure each emitted x-ray energy and 

stores them in “bins” as a histogram, or “spectrum.” The X-ray analysis software, XRS-FP, processes 

these “raw” spectra to obtain elemental peak areas that when divided by the acquisition time are known 

as intensities (counts per second, c/s). These values can then be used to determine the elemental 

concentration and/or sample thickness, using the so-called Fundamental Parameters (FP) method. 

XRF is capable of analyzing most elements in the periodic table non-destructively, and is therefore one 

of the most versatile analytical techniques currently available (Willis, Turner, & Pritchard, 2011).  

The XRS-FP software consists of a main program that provides the user interface, and various 

hardware input and output functions, together with at least two libraries (DLL’s) that provide the 

spectrum processing and FP calculations. It runs on standard PC’s, and operating systems 

(Windows  8, 7, Vista, XP, 98, etc.), with 512 MB RAM of memory. 

Complete XRF analysis is possible, with or without standards, using an internal database of 

fundamental parameters (FP) such as absorption coefficients, fluorescence yields, transition 

probabilities, etc., and complete modeling of detectors and sources. Spectrum processing libraries are 

available for removing spectrum artifacts (escape and sum peaks), background and for various least-

squares peak-fitting models using synthetic Gaussian or experimental reference profiles. 

The typical XRF “system” (Fig. 22 below) includes an x-ray source (either an x-ray tube or radioisotope) 

and detector/electronics, together with a sample within a chamber, which can be evacuated or operated 

in air.  In addition, filters may be used with either the x-ray source and/or the 

 

Figure 22. XRF “system”. Key components of an XRF instrument are shown above. This includes the source (x-ray tube or 
radioisotope), the sample and sample holder, the detector, an amplifier and signal processor and a computer for data 
acquisition, system control and for sample analysis using XRS-FP software. 

 

detector.  It is extremely important to know the geometry of your system and details about the 

components before setting up the XRS-FP software and doing any calibration or analysis work. 
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As briefly described above, the purpose of XRF analysis with FP is to convert elemental peak intensities 

(see previous section) to elemental concentrations and/or film thicknesses. This is achieved typically 

though a calibration step, where the XRF response function (related to parameters that are independent 

of the sample matrix) for each element is measured using a known standard of some kind. In some 

circumstances the analysis may be purely based upon theoretical equations, and the fundamental-

parameter database, without any need for a calibration step. This is possible for simple bulk materials 

or single-layer films where the thickness is fixed, assuming the results can be normalized to 100%. 

There are typically two steps in XRF analysis, whether or not the FP method is used.  The first step is 

to calibrate each element from one or several standards (called the FP “Calibration” step).  The second 

step is to produce the sample analysis of a given material, using the previously stored calibration 

coefficients, and the FP-based algorithms given a definition of the sample (i.e., elements, layers, and 

the distribution of the elements in the layers). 


